Author Topic: QSXM2 build - TRANSISTORS ARE RED HOT!!!  (Read 3863 times)

0 Members and 1 Guest are viewing this topic.

Offline AAmer75

  • New member
  • *
  • Posts: 2
  • Karma: +0/-0
  • Custom title, please change to something cool.
QSXM2 build - TRANSISTORS ARE RED HOT!!!
« on: September 13, 2011, 11:37:22 AM »
Last weekend I have compleated the assembly work onthe QSXM2 The extreme phono (RIAA) amplifier.

I have some doubts as during my measurments I hadsome inconsistency with measured values and also some heating issues with T31,T33,T35,T32,T34,T36group of transistors.

I am talking about the LEFT Channel of course, as itis the one I started with.

Therefore I need to ask you some questions and youranswer or recommendation would be most appreciated.

I am using your QSXPS -Regulated Power Supply.

1. The instruction on your web site says that  +/-15 is used, while on the PREAMPschematic  it is +/-18 volts.  Which one is true 15V or 18V?

2. I used tranzistors  MAT02 on positions T5,T23 and MAT03 onpositions T6,T24.

The resistor  R16 and R17 were replaced with 3K3 instead of  15K because of MAT transistors. Is thisresistance 3K3 of R16 and R17 OK?

3. the „begining“ of the PREAMP LEFT CHANNEL, on position R35shows voltage 1,13V,  while it should be0,926V. This causes that H1 LED has 2,105 volts, which causes voltagedecreasement on R43,R45,R47,R42,R44,R46,R47 for – (minus) 0,515V, which makesthe tranzistor group (T31,33,35,32,34,36) to have huge disipation, close to itsruin – THESE ARE RED HOT!!!

My MAIN question to you is the related to fixing theheating problem of course.

3. Would  theincreasement of resistance  for theresistance group (R42-47) from 22R to 33R fix the problem with Transistor group(T31,33,35,32,34,36) HEATING problem?

I think that with the resistance increasementfrom 22 Ohm to 33 Ohm I should get the proper current value through thetransistor group (T31,33,35,32,34,36) and reach the required voltage  0,320 mV on the R42-R47,  thus this HEATING problem should be fixed.

 Please seethe attached images below for better  reference.

I would need your opinion on this as well as anyother recommendation or advice for fixing the heating problem.

Offline peranders

  • Administrator
  • Reached Nirvana
  • *****
  • Posts: 1230
  • Karma: +6/-0
  • Gender: Male
  • Forum owner
    • Sjöström Audio
Re: QSXM2 build - TRANSISTORS ARE RED HOT!!!
« Reply #1 on: September 13, 2011, 10:02:48 PM »
+- 15 V is recommend due to heat but despite from that most things seems normal although the current in the output stage is a bit high. Right now you have 11 mA in the VAS stage and the best thing to reduce the current is shunt the LED current with a resistor. It's hard to calculate but the end result should be 1.6 V across the LED. Let's say the LED wants 2 mA for 1.6 V, then the resistors should be 1.6/9mA =>178 ohms, 150 or 180 ohms perhaps.
/Per-Anders Sjöström, owner of this forum

Homepage with my DIY hifi stuff