Author Topic: SSR-03 gives too low voltage on -Uout  (Read 804 times)

0 Members and 1 Guest are viewing this topic.

Offline Maikel

  • Member
  • **
  • Posts: 7
  • Karma: +0/-0
  • Custom title, please change to something cool.
SSR-03 gives too low voltage on -Uout
« on: February 17, 2018, 09:52:49 AM »
Hi Per Anders,

I just powered up my SSR03. Its the 9V edition, but when I measure without or with a load -Uout doesn't give the correct voltage.
This is what I measure unloaded: -Uout:-4,89=    +Uout:+9,09=
Loaded with 1k ohm resistor: -Uout:-4,81=    +Uout:+9,09=
When I turn off power the led on de -Uout stays on around 3 seconds longer than the led on +Uout

I made a mistake when connecting the (AC2) the first time because I connected the phase on ground, and ground on phase. Because it's AC that shouldn't make a difference? Or could it be that I damaged something?
I measure the same values now when connected in the correct way.

I also measured AC1 and AC2 inputs and they are both 14,68V~
I also measured X2 (right after the C's): -U to gnd:-18,72=    +U to gnd:18,52=

The cooling block don't get warm.

Could you give me some guidance please?

Offline peranders

  • Administrator
  • Reached Nirvana
  • *****
  • Posts: 1227
  • Karma: +6/-0
  • Gender: Male
  • Forum owner
    • Sjöström Audio
Re: SSR-03 gives too low voltage on -Uout
« Reply #1 on: February 17, 2018, 11:19:18 AM »
have you shorted the J1-4 with a tin drop?

The positive half seems to work.

Can you measure the voltage on the opamps?

N1, pin 2, 3, 6 and 7

N3, pin 2, 3, 4 and 6
/Per-Anders Sjöström, owner of this forum

Homepage with my DIY hifi stuff

Offline Maikel

  • Member
  • **
  • Posts: 7
  • Karma: +0/-0
  • Custom title, please change to something cool.
Re: SSR-03 gives too low voltage on -Uout
« Reply #2 on: February 17, 2018, 05:41:35 PM »
have you shorted the J1-4 with a tin drop?
I think I did, will check tomorrow
Quote
The positive half seems to work.

Can you measure the voltage on the opamps?

N1, pin 2, 3, 6 and 7

N3, pin 2, 3, 4 and 6
I will measure tomorrow, will let you know.   

Offline Maikel

  • Member
  • **
  • Posts: 7
  • Karma: +0/-0
  • Custom title, please change to something cool.
Re: SSR-03 gives too low voltage on -Uout
« Reply #3 on: February 18, 2018, 09:29:57 AM »
have you shorted the J1-4 with a tin drop?
Yes I have. I measure shorts (0 ohm)between X5 and +Uout and X7 to ground
For the negative half shorts (0 ohm) between X4 to -Uout and X6 to ground

Quote
The positive half seems to work.
Yes that seems the case

Quote
Can you measure the voltage on the opamps?

N1, pin 2, 3, 6 and 7
N1 AD825ARZ +Uout
Pin 2: 4,54V
Pin 3: 4,54V
Pin 6: 5,51V
Pin 7: 8,81V

N2 AD825ARZ -Uout
Pin 2: -2,43V
Pin 3: -2,94V
Pin 6: -3,88V
Pin 7: 0V

Quote
N3, pin 2, 3, 4 and 6
I don't use DIL, but I have the AD825ARZ smd IC's soldered by you on my board

Just studied the schematic and looked in the photo of negative half on your website and I soldered the diode zener DZ2 in the wrong direction. I will correct that right now and measure again

Offline Maikel

  • Member
  • **
  • Posts: 7
  • Karma: +0/-0
  • Custom title, please change to something cool.
Re: SSR-03 gives too low voltage on -Uout
« Reply #4 on: February 18, 2018, 10:37:53 AM »
+Uout still gives me 9,09V
-Uout gives me 9,21V

Is there an option to get -Uout also at -9,09V ?
Can I just add an P4 trim pot or do I have to change anything? What value can I best use for this?
« Last Edit: February 18, 2018, 10:55:02 AM by Maikel »

Offline peranders

  • Administrator
  • Reached Nirvana
  • *****
  • Posts: 1227
  • Karma: +6/-0
  • Gender: Male
  • Forum owner
    • Sjöström Audio
Re: SSR-03 gives too low voltage on -Uout
« Reply #5 on: February 18, 2018, 12:25:51 PM »
Can you measure around N2, pin 2, 3, 4 and 6

If you have 9.21 V out then you should have 4.605 V across the LM431. Is that the case?
/Per-Anders Sjöström, owner of this forum

Homepage with my DIY hifi stuff

Offline Maikel

  • Member
  • **
  • Posts: 7
  • Karma: +0/-0
  • Custom title, please change to something cool.
Re: SSR-03 gives too low voltage on -Uout
« Reply #6 on: February 18, 2018, 05:06:05 PM »
Can you measure around N2, pin 2, 3, 4 and 6

If you have 9.21 V out then you should have 4.605 V across the LM431. Is that the case?
N2 (-Uout):
Pin 2: -4,60V
Pin 3: -4,60V
Pin 4: -8,93V
Pin 6: -5,62V

LM431:
Pin 2 is ground is top pin next to VR2 text (as my reference)
I don’t know if ‘across’ means between pin 2 and 3: that’s -2,06V (-Uout)
Measured between 2 and 3 on VR1 is 2,03V (+Uout)

Measured VR2 between pin 1 and 3 is -2,53V

Sorry if I give too much info but try to be clear.
Are these the right measurements?

Offline peranders

  • Administrator
  • Reached Nirvana
  • *****
  • Posts: 1227
  • Karma: +6/-0
  • Gender: Male
  • Forum owner
    • Sjöström Audio
Re: SSR-03 gives too low voltage on -Uout
« Reply #7 on: February 18, 2018, 09:33:37 PM »
it seems to work now.

You have 4.56 as reference => times 2 = 9.12 V

4.60 V on both pin 2 and 3 = feedback is working.
/Per-Anders Sjöström, owner of this forum

Homepage with my DIY hifi stuff

Offline Maikel

  • Member
  • **
  • Posts: 7
  • Karma: +0/-0
  • Custom title, please change to something cool.
Re: SSR-03 gives too low voltage on -Uout
« Reply #8 on: February 19, 2018, 01:27:02 AM »
it seems to work now.

You have 4.56 as reference => times 2 = 9.12 V

4.60 V on both pin 2 and 3 = feedback is working.
Where can I measure that 4.56V reference voltage?
My output is 9,21V but you are talking about 9.12V
Do I need to use a formula?

Can I add the P4 trim pot to adjust the output voltage on -Uout or do I change anything?

Thank you very much for all your answers

Offline peranders

  • Administrator
  • Reached Nirvana
  • *****
  • Posts: 1227
  • Karma: +6/-0
  • Gender: Male
  • Forum owner
    • Sjöström Audio
Re: SSR-03 gives too low voltage on -Uout
« Reply #9 on: February 19, 2018, 06:25:47 AM »
The summary is that it works and I can't imagine that you'll need exactly 9.0 volts. I think you should stop here.
/Per-Anders Sjöström, owner of this forum

Homepage with my DIY hifi stuff

Offline Maikel

  • Member
  • **
  • Posts: 7
  • Karma: +0/-0
  • Custom title, please change to something cool.
Re: SSR-03 gives too low voltage on -Uout
« Reply #10 on: February 19, 2018, 01:26:42 PM »
The summary is that it works and I can't imagine that you'll need exactly 9.0 volts. I think you should stop here.
I just got confirmation that a slight difference in the two outputs shouldn’t be a problem to feed the board. Thank you for your help Per Anders!