Author Topic: QRV-08 power up  (Read 4133 times)

0 Members and 1 Guest are viewing this topic.

Offline svarthvitt

  • Member
  • **
  • Posts: 21
  • Karma: +0/-0
  • Custom title, please change to something cool.
Re: QRV-08 power up
« Reply #30 on: February 26, 2019, 02:27:42 PM »
Ok, the power supply is not working when i cut the four lines. Where do I go from here?

Offline peranders

  • Administrator
  • Reached Nirvana
  • *****
  • Posts: 1244
  • Karma: +6/-0
  • Gender: Male
  • Forum owner
    • Sjöström Audio
Re: QRV-08 power up
« Reply #31 on: February 26, 2019, 09:33:31 PM »
Which power supply doesn't work?
« Last Edit: March 25, 2019, 06:52:37 PM by peranders »
/Per-Anders Sjöström, owner of this forum

Homepage with my DIY hifi stuff

Offline svarthvitt

  • Member
  • **
  • Posts: 21
  • Karma: +0/-0
  • Custom title, please change to something cool.
Re: QRV-08 power up
« Reply #32 on: March 25, 2019, 06:30:28 PM »
The two in the middle. The leds stop shining after about five seconds.

Offline peranders

  • Administrator
  • Reached Nirvana
  • *****
  • Posts: 1244
  • Karma: +6/-0
  • Gender: Male
  • Forum owner
    • Sjöström Audio
Re: QRV-08 power up
« Reply #33 on: March 25, 2019, 06:53:29 PM »
What is the values of the output voltages?
/Per-Anders Sjöström, owner of this forum

Homepage with my DIY hifi stuff

Offline svarthvitt

  • Member
  • **
  • Posts: 21
  • Karma: +0/-0
  • Custom title, please change to something cool.
Re: QRV-08 power up
« Reply #34 on: May 02, 2019, 08:18:30 PM »
These are the values. I noted the fuse number on the rails i measured. (In parenthesis the values after some seconds, when the amp fails)

F1 +13,8v (5v)
F2 - 13,8v
F3 +13,8v
F4 -13,8v (-5,5v)

Offline peranders

  • Administrator
  • Reached Nirvana
  • *****
  • Posts: 1244
  • Karma: +6/-0
  • Gender: Male
  • Forum owner
    • Sjöström Audio
Re: QRV-08 power up
« Reply #35 on: May 03, 2019, 06:57:28 AM »
Is this the output from the regulators? Is the voltage at each amplifier zero(should be since you have cut the connection)? Can you notice any heated component?
/Per-Anders Sjöström, owner of this forum

Homepage with my DIY hifi stuff

Offline svarthvitt

  • Member
  • **
  • Posts: 21
  • Karma: +0/-0
  • Custom title, please change to something cool.
Re: QRV-08 power up
« Reply #36 on: May 13, 2019, 01:34:24 PM »
This is at the output of the lines from the psu that i have cut previously.

I will have a look with a thermal camera.

Offline peranders

  • Administrator
  • Reached Nirvana
  • *****
  • Posts: 1244
  • Karma: +6/-0
  • Gender: Male
  • Forum owner
    • Sjöström Audio
Re: QRV-08 power up
« Reply #37 on: May 15, 2019, 06:30:01 AM »
One positive regulator works the other doesn't afters one time. It means that most parts are in the right place. The two halves of the pub's are indentical so compare especially how electrolytic caps are mounted. You have probably made same mistake for the negative regulator.
/Per-Anders Sjöström, owner of this forum

Homepage with my DIY hifi stuff

Offline svarthvitt

  • Member
  • **
  • Posts: 21
  • Karma: +0/-0
  • Custom title, please change to something cool.
Re: QRV-08 power up
« Reply #38 on: May 21, 2019, 11:03:53 PM »
I have measured all the electrolytics in the psu, and all the resistors. When still on the pcb, they all measure the same.

When I watch the amp power up with a termal camera, the only thing really different is the rectifiers. The two in the middle (the two failing ones) gets really hot. When I measure resistance across these, I get almost a short between the ac and the positive on the two failing ones, but the working ones show several megaohms.

Should I simply order new ones, or do you think these are only symptoms for another error?


Thank you for following me through this so far!

Offline peranders

  • Administrator
  • Reached Nirvana
  • *****
  • Posts: 1244
  • Karma: +6/-0
  • Gender: Male
  • Forum owner
    • Sjöström Audio
Re: QRV-08 power up
« Reply #39 on: Yesterday at 07:39:30 PM »
Switch over to "diode" on your DVM and measure the diodes in the rectifier bridges. If you read near zero, the you probably have broken diodes => change the parts.
/Per-Anders Sjöström, owner of this forum

Homepage with my DIY hifi stuff